Help

DiscussCategory: General questionsGetting error {code: 1000, Ooops something went wrong}
Vit Bokisch asked 1 year ago

Hello,

we started getting an error {code: 1000, Ooops something went wrong} due to an unknown reason. We are using BeeFree plugin. We haven’t make any changes in our configuration or so, nor even major/breaking changes in last few weeks in the app. So I would like to ask, did you make any changes which could break behavior of the plugin? Everything seems to work fine, except when any template loads. There is one request failing https://rsrc.getbee.io/api/nlparser?p=false (its’ always the last request, all previous requests seems to be ok) due tu unknown reason and shows that error. I can create new template, I can edit and save templates. But when templates get loaded an error will appear. Thank you.

Best regards,

Vit

3 Answers
Vit Bokisch answered 1 year ago

Additional info which may help about the request:

POST /api/nlparser?p=false HTTP/1.1

Host: rsrc.getbee.io

Connection: keep-alive

Content-Length: 13

Pragma: no-cache

Cache-Control: no-cache

Accept: application/json, text/plain, /

Origin: https://app.getbee.io

Authorization: TOKEN

User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.139 Safari/537.36

Content-Type: application/json;charset=UTF-8

Referer: https://app.getbee.io/v18.05.28.1053/index.html

Accept-Encoding: gzip, deflate, br

Accept-Language: en-GB,en-US;q=0.9,en;q=0.8

payload: {"page":null}

Guillermo Padilla answered 1 year ago

Hi Vit, we answered your ticket with some details that we need for a proper diagnosis.

Matt Weber answered 1 year ago

Following-up, for anyone that comes across this error, it’s caused by calling "save()" or "preview()" before the template loads. The best solution is to wait for the "onLoad()" callback before using these methods. That will ensure the template is fully loaded, therefore, "save()" and "preview()" can return the HTML.

Your Answer